openhatch

Issue282

Title Decide on user interface for creators/owners responding to (and mark as 'responded to') people who clicked 'I wanna help'
Milestone 0.11.07 Priority urgent
Waiting On Status resolved
Superseder Implement the new IWH handler page
View: 567
Nosy List aldeka, glyph, jessica, jesstess, johnobrien10, palhmbs, paulproteus, pnob32
Assigned To Keywords this-would-rock, usability

Created on 2011-02-12.21:41:03 by aldeka, last changed 2011-11-14.01:34:43 by paulproteus.

Files
File name Uploaded Type Edit Remove
iwh-handler.png aldeka, 2011-08-27.02:52:01 image/png
iwh-mockup.png aldeka, 2011-04-11.23:04:09 image/png
Messages
msg2681 (view) Author: paulproteus Date: 2011-11-14.01:34:42
The UI design is done, so marking this as resolved.

issue567 covers the implementation.
msg2678 (view) Author: paulproteus Date: 2011-11-13.23:07:30
The design is done, but the implementation remains to be done.
msg2615 (view) Author: johnobrien10 Date: 2011-11-08.14:53:49
Unfortunately, I couldn't get Vagrant working for me. Sorry Asheesh.
msg2614 (view) Author: paulproteus Date: 2011-11-08.00:58:11
Hi John!

In case you want to try using Vagrant, which lets you run the code in a virtual
machine:

https://openhatch.org/wiki/Using_OpenHatch_with_Vagrant
msg2613 (view) Author: johnobrien10 Date: 2011-11-08.00:05:38
I will try to do this.
msg2390 (view) Author: aldeka Date: 2011-08-27.21:15:35
A couple changes:

'Contacted' people (on load; not when you just clicked the Contact checkmark)
should look greyed out somehow.

Change the top tab text from "IWH handler" to "Prospective helpers".

If you aren't logged in and a current contributor to this project, the
"Prospective helpers" tab lists a list of helpers without the contact interface
(checkbox, remove link, huge email link). Like the current list of IWHelpers in
the sidebar (which we would remove). At the top, there should be some text
telling people "If you are a contributor to this project, add it to your profile
and you will be able to contact these people from this page" or somesuch.

Now I'll go make some feature request bugs for actually implementing this stuff.
msg2387 (view) Author: paulproteus Date: 2011-08-27.06:02:44
I am marking this as need-review. Anyone on Devel, feel free to look at
"iwh-handler.png" and provide feedback.
msg2386 (view) Author: aldeka Date: 2011-08-27.02:52:01
Yay, a mockup!

Some notes:

By default, people are sorted first by whether or not they've been contacted
(uncontacted first), then by date. You can also sort purely by date (reverse
chronological order) or by name (alphabetical).

The person's name and profile picture link to their profile. The email address
is a mailto: link.

The date is the date that they clicked the 'I wanna help' button. "Wants to
help" is an optional extra field that the person can fill out, that appears
after they click the 'I wanna help' button. (UI mockups for that functionality
forthcoming.)

When a person is checked off as contacted, the project maintainer who checked
that button is recorded as the person who contacted them.

The "Remove" link removes the person from the list of wannahelpers.

Hopefully that's all reasonably clear!
msg2270 (view) Author: aldeka Date: 2011-08-07.07:19:40
http://openhatch.org/people/?q=icanhelp:%22OpenHatch%22

Sigh. What a non-useful web page (for really learning about or contacting anyone, 
anyway). 

Whenever this gets fixed, we should remember to change the See All >> link in the 
right-hand list of wannahelpers to change to the wannahelper handler tab instead 
of taking you to /people/.
msg1781 (view) Author: paulproteus Date: 2011-05-01.07:55:10
We got close on this, but not quite. Maybe in the next few days someone can flesh 
out the project page tab idea, which I think I eventually convinced aldeka of.

Moving to 0.11.05! I'd love to see the design decided.
msg1700 (view) Author: aldeka Date: 2011-04-23.16:43:53
Currently, as designed, there is no actual contacting functionality in the IWH
widget (other than the mailto: links under each person's name, I guess). It's
actually *really* simple. What 'contact' and 'contacted' are are just a toggle
so that you (the project lead / outreach guru / whatever) can note to yourself
(and anyone else in the project) who's been contacted and who you haven't. If
you scroll, you can see everybody who's ever clicked IWH, but the people who
haven't been marked as 'contacted' appear first in the list.

I don't especially like the idea of hiding the entirety of IWH on a separate
project page tab -- seems like that would make it exceptionally easy to ignore
or forget about, at least until we have an IWH widget for the logged-in
dashboard. (In which case, we're gonna need a mini version of the UI *anyway*.) 

Also, of the extra features you list, really the only one that this doesn't
already have is the comma-delimited, email-ready mass list. We could probably
replace the old 'See all' link at the top of the widget with a link to generate
that.
msg1494 (view) Author: paulproteus Date: 2011-04-14.04:24:26
Seeing this makes me think: "Gosh, that's a lot of functionality in that little
box."

Some thoughts:

* The Project page could maybe have two modes -- one where you can deal with the
wannahelpers, and another where you see the questions&answers. It's a lot of UI
jam-packed into that tiny box.

* What happens when you click "Contact"?

* The box only shows a subset of the wannahelpers. The subset that it shows
should prioritize people who have not been checked-off as contacted.

* There should be a way to "Clear all" contacted status, so that we can tell
people, "If you want to reach out to people for a hackathon, you can un-check
all, and then get all their email addresses."

* There should be a way to list all email addresses of un-contacted
wannahelpers, separated by a comma, so that you can send one big mass email.

I know that my giving this feedback super-late means we're not going to "Decide"
on the user interface for this milestone. But I think it's okay that it's taken
a bit longer if we're going to end up with a higher-quality resulting UI.

If it's not too tiring, let's keep the conversation going.
msg1474 (view) Author: palhmbs Date: 2011-04-11.23:14:33
+1 - I like it.
msg1473 (view) Author: aldeka Date: 2011-04-11.23:04:09
It is a mockup! (finally) (augh)

It could probably be less ugly, and I decided to leave out the bugtracker adder
for now, but maybe this gives a sense of how the info could be organized?
msg1398 (view) Author: paulproteus Date: 2011-03-30.22:19:03
Karen says a date to hope for this is April 10.

To make this fit within the milestone, I changed the bug's Title to adjust the
scope down to refer to UI decisions. It'll be good that that's happening
alongside the release; we can ask people for feedback before implementing it.
msg1237 (view) Author: aldeka Date: 2011-03-12.21:23:51
Also, let's add the automagical bugtracker adder to the project page 
(http://openhatch.org/customs/). Or at least a link to it!
msg1236 (view) Author: aldeka Date: 2011-03-12.21:18:16
A UI mockup would be good, for what this interface ought to look like / where it 
should live. Assigning to self, at least for that step.
msg1211 (view) Author: paulproteus Date: 2011-03-01.06:23:22
This is getting there, I understand, but not totally ready. Targeting for 0.11.03.
msg1051 (view) Author: paulproteus Date: 2011-02-13.03:24:34
I think jesstess means issue287
msg1041 (view) Author: jesstess Date: 2011-02-12.22:19:46
http://openhatch.org/bugs/issue282 is tracking implementing a way for contributors to specify 
which projects they want notifications for.
msg1033 (view) Author: aldeka Date: 2011-02-12.21:45:03
Ideally, this would include a form on OH which the contributor can use to email
the person back. But, dang, even just having easy access to everybody's email
address/email forwarder + a way to mark as contacted would be better than what
we got...
msg1031 (view) Author: aldeka Date: 2011-02-12.21:41:35
Of course, this requires us to identify which contributors consider themselves
"owners" or what have you...
msg1029 (view) Author: aldeka Date: 2011-02-12.21:41:03
Because, like, lolduh.
History
Date User Action Args
2011-11-14 01:34:43paulproteussetstatus: chatting -> resolved
messages: + msg2681
2011-11-13 23:07:30paulproteussetsuperseder: + Implement the new IWH handler page
messages: + msg2678
2011-11-08 14:53:50johnobrien10setassignedto: johnobrien10 ->
messages: + msg2615
2011-11-08 00:58:14paulproteussetmessages: + msg2614
2011-11-08 00:05:48johnobrien10setstatus: resolved -> chatting
assignedto: aldeka -> johnobrien10
messages: + msg2613
nosy: + johnobrien10
2011-08-27 21:15:37aldekasetstatus: need-review -> resolved
messages: + msg2390
2011-08-27 06:02:44paulproteussetstatus: in-progress -> need-review
messages: + msg2387
2011-08-27 02:52:02aldekasetfiles: + iwh-handler.png
messages: + msg2386
2011-08-07 07:55:31aldekaunlinkissue330 blockers
2011-08-07 07:46:18aldekasetassignedto: aldeka
2011-08-07 07:19:40aldekasetmessages: + msg2270
2011-07-02 20:11:17palhmbssetmilestone: 0.11.06 -> 0.11.07
2011-06-11 20:53:25aldekasetassignedto: aldeka -> (no value)
2011-05-28 22:38:35palhmbslinkissue330 blockers
2011-05-28 22:05:41palhmbssetkeyword: + usability, this-would-rock
2011-05-28 22:04:35palhmbssetmilestone: 0.11.05 -> 0.11.06
2011-05-01 07:55:10paulproteussetmessages: + msg1781
milestone: 0.11.04 -> 0.11.05
2011-04-30 20:34:21jessicasetnosy: + jessica
2011-04-23 16:43:54aldekasetmessages: + msg1700
2011-04-22 02:48:50glyphsetnosy: + glyph
2011-04-14 04:24:26paulproteussetmessages: + msg1494
milestone: 0.11.03 -> 0.11.04
2011-04-11 23:14:33palhmbssetmessages: + msg1474
2011-04-11 23:04:09aldekasetstatus: chatting -> in-progress
files: + iwh-mockup.png
messages: + msg1473
2011-03-30 22:19:03paulproteussetmessages: + msg1398
title: Project creators/owners can respond to (and mark as 'responded to') people who clicked 'I wanna help' -> Decide on user interface for creators/owners responding to (and mark as 'responded to') people who clicked 'I wanna help'
2011-03-26 21:29:48aldekasetmilestone: 0.11.04 -> 0.11.03
2011-03-26 19:03:10aldekasetmilestone: 0.11.03 -> 0.11.04
2011-03-21 08:20:23palhmbssetnosy: + palhmbs
2011-03-12 21:23:51aldekasetmessages: + msg1237
2011-03-12 21:18:16aldekasetassignedto: pnob32 -> aldeka
messages: + msg1236
2011-03-01 06:23:22paulproteussetmessages: + msg1211
milestone: 0.11.02 -> 0.11.03
2011-02-19 22:24:14pnob32setassignedto: pnob32
nosy: + pnob32
2011-02-13 03:24:35paulproteussetmessages: + msg1051
2011-02-12 22:19:46jesstesssetmessages: + msg1041
2011-02-12 21:45:03aldekasetmessages: + msg1033
2011-02-12 21:41:53aldekasetnosy: + jesstess
2011-02-12 21:41:35aldekasetstatus: unread -> chatting
messages: + msg1031
2011-02-12 21:41:03aldekacreate